Original iPhone and iPhone 3G no longer supported with AIR for iOS.

I wish I knew this earlier. I have recently begun trying some experiments with the Box2d WCK ( World Construction Kit ) running on iOS devices through AIR. While I have used it for a brief period 6 months previously during December 2010, a lot has moved on since then. One of the new updates to AIR, specifically the large 2.6 update, rendered my iPhone 3G hardware useless. So it looks like I really need a new phone pretty soon. Damn!

If you try and export a new IPA file from Adobe Flash CS5.5 and run it on iOS3, you will receive this irritating message:

The app “APP NAME” was not installed on the iPod/iPad/iShit “DEVICE NAME” because it is not compatible with this iPod/iPad/iShit”

Thankfully, I was able to find this Adobe release announcing the change. Wish I new this before automatically assuming it was those pesky certificates!

As part of supporting the latest and most powerful Flash runtime features on iOS, we have chosen to drop support for the original iPhone and the iPhone 3G, along with iPhone OS 3. AIR 2.6 supports building apps for the following iOS 4 devices:

  • iPhone 3GS and iPhone 4
  • iPod Touch (3rd Generation and 4th Generation)
  • iPad

Source: http://www.adobe.com/devnet/air/articles/whats-new-in-air-26.html

Share on FacebookTweet about this on TwitterShare on Google+Share on LinkedInShare on RedditShare on StumbleUponShare on TumblrEmail this to someone

Leave a Reply

Your email address will not be published.